aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2015-10-08 16:10:23 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-10-12 09:03:15 +0200
commitcdeb815c78f4cdd5eb38995ea3f8550c637a1561 (patch)
treeb86295be57ce68422e60e9b6837f3805f9f2070f /openbsc/tests/channel/Makefile.am
parentb3cbd9aa3b8e80060ff38b975e297a5b4a850fec (diff)
libmsc: Use RAND_bytes when choosing a tmsi
Require openssl version to be >= 0.9.5 because we rely on the RAND_bytes return value. [hfreyther: Add cast to uint8_t*]
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
index 519efbd7f..51b2f83cb 100644
--- a/openbsc/tests/channel/Makefile.am
+++ b/openbsc/tests/channel/Makefile.am
@@ -11,4 +11,4 @@ channel_test_LDADD = \
$(top_builddir)/src/libmsc/libmsc.a \
$(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) \
- -ldbi $(LIBOSMOGSM_LIBS)
+ -ldbi $(LIBOSMOGSM_LIBS) $(LIBCRYPTO_LIBS)