aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-10-13 12:38:54 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-10-22 15:23:58 +0200
commit511f9c3e4a0a7ebb6294d6a2e4ac29dbcdad818c (patch)
treef3f8cfc0b9a5a3a62f2fa8c550f9dd7435740fa8 /openbsc/tests/Makefile.am
parentd49eb747325e2745fb3cfa6da9d63ec302b4dc9d (diff)
si: Partially implement the range encoding for the SI.
I saw the old copy of the "Appendix J" code too late and I have discovered some quirks and I am more familar with my implementation. Most noticable 'w' only needs to be as big as the input arfcn but requires the 'w' to be initialized. The power_of_2 implementation differs as well (mine matches the output of wirehsark). The f0 could be chosen in a better way but right now picking the lower bound is the easiest. It is not clear if to use modulo if the range is chosen in the middle. This can be improved in the future. Right now I have no bit fiddling for range128, 256 and 1024 as I was running out of time.
Diffstat (limited to 'openbsc/tests/Makefile.am')
-rw-r--r--openbsc/tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/tests/Makefile.am b/openbsc/tests/Makefile.am
index 84dbd922c..cede8e824 100644
--- a/openbsc/tests/Makefile.am
+++ b/openbsc/tests/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = gsm0408 db channel mgcp gprs
+SUBDIRS = gsm0408 db channel mgcp gprs si
if BUILD_NAT
SUBDIRS += bsc-nat