aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/utils/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-23 23:35:01 +0100
committerHarald Welte <laforge@gnumonks.org>2012-11-24 11:09:21 +0100
commitc0de14da8f868de3a68b485ec382d8aa7dabbec9 (patch)
tree396eba9b382b7b3c88f3c1b3b6c52e472bfe647e /openbsc/src/utils/Makefile.am
parente07b6a77e51f19b45d3ca0a7b3b4014ffeb40859 (diff)
SMPP: add small utility program 'smpp_mirror'
This program binds as ESME transceiver to a SMSC and simply mirrors back all SMS that it receives.
Diffstat (limited to 'openbsc/src/utils/Makefile.am')
-rw-r--r--openbsc/src/utils/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/openbsc/src/utils/Makefile.am b/openbsc/src/utils/Makefile.am
index c5b6a7add..701e9b86b 100644
--- a/openbsc/src/utils/Makefile.am
+++ b/openbsc/src/utils/Makefile.am
@@ -4,6 +4,10 @@ AM_LDFLAGS = $(COVERAGE_LDFLAGS)
bin_PROGRAMS = bs11_config isdnsync
+if BUILD_SMPP
+noinst_PROGRAMS = smpp_mirror
+endif
+
bs11_config_SOURCES = bs11_config.c
bs11_config_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
$(top_builddir)/src/libbsc/libbsc.a \
@@ -11,3 +15,7 @@ bs11_config_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOABIS_LIBS)
isdnsync_SOURCES = isdnsync.c
+
+smpp_mirror_SOURCES = smpp_mirror.c
+smpp_mirror_LDADD = $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) $(LIBSMPP34_LIBS)