aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libmgcp/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-09-07 13:39:07 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-01-23 13:56:01 +0100
commit6c03b463aaa833e12f6d2aadda524b65a7b10c61 (patch)
tree3c98bbcdc21eedec23babf559ab2edf5510aab53 /openbsc/src/libmgcp/Makefile.am
parentc5f62e3789d25d9bfec2f91f97fecf1085f9f7f4 (diff)
libmgcp: add mgcpgw client API
Add an API to send MGCP messages to an MGCP GW, from the perspective of an MSC instructing the GW to setup RTP streams. Rationale: the mgcp_protocol.h is mostly for the MGCP GW itself, other implementations forward incoming MGCP messages. So a simpler approach for an MGCP GW client is useful. Add general VTY commands that can be used to configure mgcpgw_client. osmo-cscn is going to use this to route RTP streams (for 3G at first). Change-Id: I6fe365c4c89207f2172943cc456b508a207b1135
Diffstat (limited to 'openbsc/src/libmgcp/Makefile.am')
-rw-r--r--openbsc/src/libmgcp/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/openbsc/src/libmgcp/Makefile.am b/openbsc/src/libmgcp/Makefile.am
index 34a8fb743..5d7844da4 100644
--- a/openbsc/src/libmgcp/Makefile.am
+++ b/openbsc/src/libmgcp/Makefile.am
@@ -36,6 +36,8 @@ libmgcp_a_SOURCES = \
mgcp_vty.c \
mgcp_osmux.c \
mgcp_sdp.c \
+ mgcpgw_client.c \
+ mgcpgw_client_vty.c \
$(NULL)
if BUILD_MGCP_TRANSCODING
libmgcp_a_SOURCES += \