aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libfilter/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-03 22:34:01 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-03 22:34:16 +0200
commit337343d159888886eaa68476b70dbe19db93845b (patch)
tree318a8135477e0dcc8f8e24d2380342c254ab9d60 /openbsc/src/libfilter/Makefile.am
parent38159428d2b1e95a2c6fa91775f7b3678aef2f1f (diff)
parentd26b8fcbe22eb4a56c87f0114a0e826551243511 (diff)
Merge branch 'zecke/features/acc-list'
Integrate the change and see how it is going. The unit tests for the NAT look good so we might not have regressions.
Diffstat (limited to 'openbsc/src/libfilter/Makefile.am')
-rw-r--r--openbsc/src/libfilter/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/openbsc/src/libfilter/Makefile.am b/openbsc/src/libfilter/Makefile.am
new file mode 100644
index 000000000..4dbc59041
--- /dev/null
+++ b/openbsc/src/libfilter/Makefile.am
@@ -0,0 +1,11 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) \
+ $(LIBOSMOVTY_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
+
+noinst_LIBRARIES = libfilter.a
+
+libfilter_a_SOURCES = \
+ bsc_msg_filter.c \
+ bsc_msg_acc.c \
+ bsc_msg_vty.c
+