aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libctrl/Makefile.am
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2010-10-21 15:00:36 +0200
committerHarald Welte <laforge@gnumonks.org>2011-07-13 14:06:18 +0200
commit4462f8c30f744406dd7609eebf7ca1878003e14d (patch)
treec5547611355116d8ab91989b30b67e6c275ecc4a /openbsc/src/libctrl/Makefile.am
parent203d86531764d680cd73b71878263e29d1603a04 (diff)
Add libctrl, an SNMP-like control interface
In contrast to the VTY interface the control interface is meant to be used by programs. This patch adds basic support, no commands are defined.
Diffstat (limited to 'openbsc/src/libctrl/Makefile.am')
-rw-r--r--openbsc/src/libctrl/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/openbsc/src/libctrl/Makefile.am b/openbsc/src/libctrl/Makefile.am
new file mode 100644
index 000000000..286929b89
--- /dev/null
+++ b/openbsc/src/libctrl/Makefile.am
@@ -0,0 +1,7 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libctrl.a
+
+libctrl_a_SOURCES = control_if.c control_cmd.c