aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libabis/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-04 13:18:30 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-04 13:23:09 +0100
commit89579b4317a7f7ab6ee706399bee4b8f25a12c3a (patch)
tree8e66e64f14e582cd29f6b78023528297b71548ba /openbsc/src/libabis/Makefile.am
parent5a6b68f4169c0ef55dca02a9644ee8f3bbc97e60 (diff)
prefix sub-directories containing libraries with 'lib'
... and make sure tests work again after restructuring
Diffstat (limited to 'openbsc/src/libabis/Makefile.am')
-rw-r--r--openbsc/src/libabis/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/openbsc/src/libabis/Makefile.am b/openbsc/src/libabis/Makefile.am
new file mode 100644
index 000000000..7f5ac47cc
--- /dev/null
+++ b/openbsc/src/libabis/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libabis.a
+
+libabis_a_SOURCES = e1_input.c e1_input_vty.c \
+ input/misdn.c \
+ input/ipaccess.c \
+ input/dahdi.c \
+ input/lapd.c
+
+EXTRA_DIST = input/lapd.h