aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/ipaccess/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-05-04 07:47:54 +0200
committerHarald Welte <laforge@gnumonks.org>2010-05-04 07:47:54 +0200
commitc9a341b248a87c53e9e28ee2cde00e8071b5535e (patch)
treeff160b0ca4b12aa3534e634ea6e3a8cc8bf42b4a /openbsc/src/ipaccess/Makefile.am
parente236596bf42aec7520f2d7a879bb8d2aef7afad0 (diff)
move ipaccess tools into their own subdirectory
They will now be built fully inside src/ipaccess, using their own Makefile.am
Diffstat (limited to 'openbsc/src/ipaccess/Makefile.am')
-rw-r--r--openbsc/src/ipaccess/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/openbsc/src/ipaccess/Makefile.am b/openbsc/src/ipaccess/Makefile.am
new file mode 100644
index 000000000..7a13ee175
--- /dev/null
+++ b/openbsc/src/ipaccess/Makefile.am
@@ -0,0 +1,12 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS)
+
+sbin_PROGRAMS = ipaccess-find ipaccess-config ipaccess-proxy
+
+ipaccess_find_SOURCES = ipaccess-find.c
+
+ipaccess_config_SOURCES = ipaccess-config.c ipaccess-firmware.c
+ipaccess_config_LDADD = ../libbsc.a ../libmsc.a ../libbsc.a ../libvty.a -ldl -ldbi $(LIBCRYPT)
+
+ipaccess_proxy_SOURCES = ipaccess-proxy.c ../debug.c