aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.in
diff options
context:
space:
mode:
authorAlexander Huemer <alexander.huemer@xx.vu>2011-05-24 15:16:54 +0200
committerHarald Welte <laforge@gnumonks.org>2011-05-24 17:21:32 +0200
commitdb1bd6998b5546e95786cf59200921b61ced56eb (patch)
treee0b354af81715c491b2615355f13bb131059437c /openbsc/configure.in
parent80cffaf323016372276d6737793a75e26bd3d625 (diff)
openbsc: add missing AC_LANG_SOURCE for current autoconf
autoconf >=2.68 demands the body of an AC_COMPILE_IFELSE to be wrapped in an AC_LANG_SOURCE macro, otherwise outputs annoying warnings on the invocation of `autoreconf -i`. this patch follows that demand.
Diffstat (limited to 'openbsc/configure.in')
-rw-r--r--openbsc/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/configure.in b/openbsc/configure.in
index e9bc079b4..74b30448c 100644
--- a/openbsc/configure.in
+++ b/openbsc/configure.in
@@ -59,7 +59,7 @@ dnl Checks for typedefs, structures and compiler characteristics
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "
AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
-AC_COMPILE_IFELSE([char foo;],
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([char foo;])],
[ AC_MSG_RESULT([yes])
SYMBOL_VISIBILITY="-fvisibility=hidden"],
AC_MSG_RESULT([no]))