aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-01-10 09:51:31 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-01-10 09:54:30 +0100
commitbb06eb9d7c9c048b5297511b329f0029ecbfd9fc (patch)
tree28ff4ed9cf2b128a9702c570d01a4512c6c4bb0f /openbsc/configure.ac
parenta67704753a6328f725d38d61af8bfbe29012fcbc (diff)
meas: Unbreak the build once more
The code assumes that sqlite3.h is in the standard include path. Maybe sqlite3 wasn't installed or resides in a non standard (/usr/local) location? Fix the build as it has been broken since 1st of January.
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 3e5ae38a4..00d1b70c9 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -88,6 +88,11 @@ found_cdk=yes
AC_CHECK_HEADERS(cdk/cdk.h,,found_cdk=no)
AM_CONDITIONAL(HAVE_LIBCDK, test "$found_cdk" = yes)
+found_sqlite3=yes
+PKG_CHECK_MODULES(SQLITE3, sqlite3, ,found_sqlite3=no)
+AM_CONDITIONAL(HAVE_SQLITE3, test "$found_sqlite3" = yes)
+AC_SUBST(found_sqlite3)
+
dnl Checks for typedefs, structures and compiler characteristics