aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-13 17:09:56 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-27 20:03:10 +0200
commita7328a5642566bf7b07c6d0e58dfe5da018873a5 (patch)
tree7242bc7481b70b956a7e7b373b4d285226afe2a3 /openbsc/configure.ac
parent5ecbc93656edf49c8042b269299e31e157763511 (diff)
smpp: Move the coding/mode detection into a utils file
Make sure to not ever have issues with this code again, move the utility code to a new file and create a basic testcase. The method currently has 100% line and branch coverage. My initial patched missed the smpp_utils.c file and I re-did the copying (and verifying the branch coverage)
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index 3dd22124b..0227d2698 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -44,12 +44,13 @@ AM_CONDITIONAL(BUILD_BSC, test "x$osmo_ac_build_bsc" = "xyes")
# Enable/disable smpp support in the nitb?
AC_ARG_ENABLE([smpp], [AS_HELP_STRING([--enable-smpp], [Build the SMPP interface])],
- [osmo_ac_build_smpp="$enableval"])
+ [osmo_ac_build_smpp="$enableval"],[osmo_ac_build_smpp="no"])
if test "$osmo_ac_build_smpp" = "yes" ; then
PKG_CHECK_MODULES(LIBSMPP34, libsmpp34 >= 1.10)
AC_DEFINE(BUILD_SMPP, 1, [Define if we want to build SMPP])
fi
AM_CONDITIONAL(BUILD_SMPP, test "x$osmo_ac_build_smpp" = "xyes")
+AC_SUBST(osmo_ac_build_smpp)
found_libgtp=yes
@@ -160,6 +161,7 @@ AC_OUTPUT(
tests/gprs/Makefile
tests/si/Makefile
tests/abis/Makefile
+ tests/smpp/Makefile
doc/Makefile
doc/examples/Makefile
Makefile)