aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-23 00:09:32 +0800
committerHarald Welte <laforge@gnumonks.org>2010-03-23 00:09:32 +0800
commit5a29c7fa895a14112a1ac65e541f4b87ae9dba04 (patch)
treeebe00528c9d0b992406de8c30ab2a3e99eccdd0a /openbsc/Makefile.am
parent351ec2a1784fbdb2ce688f50a9134532f3bf0723 (diff)
automatically include program version and print it from vty and --version
Diffstat (limited to 'openbsc/Makefile.am')
-rw-r--r--openbsc/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/openbsc/Makefile.am b/openbsc/Makefile.am
index 7acae7512..4ce11cec5 100644
--- a/openbsc/Makefile.am
+++ b/openbsc/Makefile.am
@@ -6,5 +6,8 @@ SUBDIRS = include src tests
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = openbsc.pc libsccp.pc
-#dist-hook:
-# rm -rf `find $(distdir) -name .svn`
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version