aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-12-12 13:07:47 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-12-12 13:08:26 +0100
commit65f7427e025dd1962dcab2214453a66a639cf231 (patch)
tree45635852d5729ddbb4e5a9fb149708bbb5fa8d0a /debian
parent9f4f4e6c293b7956da5cdf795305de6c49bb4c8a (diff)
debian: Build debug packages for each of the target packages
Diffstat (limited to 'debian')
-rw-r--r--debian/control56
-rwxr-xr-xdebian/rules9
2 files changed, 65 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index e0d75aa74..757645560 100644
--- a/debian/control
+++ b/debian/control
@@ -42,3 +42,59 @@ Package: osmocom-bsc-nat
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libosmocore
Description: Osmocom Base Station Controller Network Address Translation
+
+Package: osmocom-bsc-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-bsc (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC BSC
+ Make debugging possible
+
+Package: osmocom-nitb-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-nitb (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC NITB
+ Make debugging possible
+
+Package: osmocom-ipaccess-utils-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-ipaccess-utils (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC ip.access utils
+ Make debugging possible
+
+Package: osmocom-bs11-utils-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-bs11-utils (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC BS11 utils
+ Make debugging possible
+
+Package: osmocom-sgsn-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-sgsn (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC Serving GPRS Support Node
+ Make debugging possible
+
+Package: osmocom-gbproxy-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-gbproxy (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC GPRS GBProxy
+ Make debugging possible
+
+Package: osmocom-bsc-nat-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmocom-bsc-nat (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the OpenBSC Network Address Translation
+ Make debugging possible
diff --git a/debian/rules b/debian/rules
index 89f96ccb8..586fa1098 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,6 +24,15 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
override_dh_autoreconf:
cd openbsc && autoreconf --install --force
+override_dh_strip:
+ dh_strip -posmocom-bsc --dbg-package=osmocom-bsc-dbg
+ dh_strip -posmocom-nitb --dbg-package=osmocom-nitb-dbg
+ dh_strip -posmocom-ipaccess-utils --dbg-package=osmocom-ipaccess-utils-dbg
+ dh_strip -posmocom-bs11-utils --dbg-package=osmocom-bs11-utils-dbg
+ dh_strip -posmocom-sgsn --dbg-package=osmocom-sgsn-dbg
+ dh_strip -posmocom-gbproxy --dbg-package=osmocom-gbproxy-dbg
+ dh_strip -posmocom-bsc-nat --dbg-package=osmocom-bsc-nat-dbg
+
override_dh_auto_configure:
echo $(VERSION) > openbsc/.tarball-version
dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc