aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-09-10 14:10:29 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-09-13 12:06:08 +0200
commit422492998660ba40d3d7986fd43e1d7aafa3774a (patch)
treede0be8bc7dd9a2afcdae65c9ffe7b0d9547233ed /debian/rules
parentac1b03c8e59408336d07527e2597171cb99ed654 (diff)
Install systemd services with autotools
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ef085960d..e37a26268 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
- dh $@ --sourcedirectory=openbsc --with autoreconf
+ dh $@ --sourcedirectory=openbsc --with=systemd --with autoreconf
# This is needed for debian stable (squeeze)
override_dh_autoreconf:
@@ -25,7 +25,7 @@ override_dh_strip:
override_dh_auto_configure:
echo $(VERSION) > openbsc/.tarball-version
- dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc --enable-smpp
+ dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc --enable-smpp --with-systemdsystemunitdir=/lib/systemd/system
# Print test results in case of a failure
override_dh_auto_test: