aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 14:43:42 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 23:01:43 +0100
commite600eed7faf12f1f6b0bc1baab667e960adf68d5 (patch)
tree456a33c76cc00b2bbba9691380041e50935e48c9 /debian/rules
parent6b55f603e3fe49b55f15ee3895699887bca13741 (diff)
debian: Move debian directory to ease building packages
This is required to have git-buildpackage be able to create tarballs from the git repository and was done by Jan in the debian branch as well.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..34ef3e7d9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+%:
+ dh --with autoreconf $@
+
+override_dh_auto_configure:
+ echo $(VERSION) > .tarball-version
+ dh_auto_configure -- --enable-nat --enable-osmo-bsc
+
+override_dh_auto_test:
+# tests are broken...