aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-12-27 09:42:59 +0000
committerHolger Freyther <zecke@selfish.org>2008-12-27 09:42:59 +0000
commit5f75598c2804380ca07a5d52a411b5b64ba57fc3 (patch)
tree668e806888d49e1f32b026b5f7b83bb8c6e733d4 /configure.in
parent5677ae35ba3e4b617c590b46f0f224a15f924e5b (diff)
Introduce a simple timer API....
One can use add_timer or schedule_timer to add a timer. After the timeout time has been reached the callback will be called. One can call add_time/schedule_timer and del_timer from within the callback.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 1c4070ccf..034972a43 100644
--- a/configure.in
+++ b/configure.in
@@ -16,4 +16,10 @@ AC_CHECK_HEADERS(mISDNif.h)
dnl Checks for typedefs, structures and compiler characteristics
-AC_OUTPUT(include/openbsc/Makefile include/Makefile src/Makefile Makefile)
+AC_OUTPUT(
+ include/openbsc/Makefile
+ include/Makefile
+ src/Makefile
+ tests/Makefile
+ tests/timer/Makefile
+ Makefile)