aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-osmocom
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-26 14:30:16 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-29 14:04:26 +0200
commit254389b473e392d97adfa666c25f1b565d2d3059 (patch)
tree7d753909b16057e226f0d01b7b652064f689b651 /recipes-osmocom
parentdf34ca271120e4f3390d3fe7b53b6c5b7763b217 (diff)
osmo-sgsn: Introduce recipe
Diffstat (limited to 'recipes-osmocom')
-rw-r--r--recipes-osmocom/osmo-sgsn/osmo-sgsn.inc41
-rw-r--r--recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb7
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
new file mode 100644
index 0000000..3669b79
--- /dev/null
+++ b/recipes-osmocom/osmo-sgsn/osmo-sgsn.inc
@@ -0,0 +1,41 @@
+DESCRIPTION = "Osmocom SGSN implementation"
+HOMEPAGE = "https://osmocom.org/projects/osmosgsn"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "c-ares libpcap libasn1c libosmocore libosmo-netif osmo-iuh osmo-ggsn"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+EXTRA_OECONF += "--enable-iu"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-sgsn/osmo-sgsn.cfg ${D}${sysconfdir}/osmocom/
+ install -m 0644 ${S}/doc/examples/osmo-gbproxy/osmo-gbproxy.cfg ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/contrib/systemd/osmo-sgsn.service ${D}${systemd_system_unitdir}/
+ install -m 0644 ${S}/contrib/systemd/osmo-gbproxy.service ${D}${systemd_system_unitdir}/
+}
+
+PACKAGES =+ "osmo-gbproxy-doc osmo-gtphub-doc osmo-gbproxy osmo-gtphub"
+SYSTEMD_PACKAGES = "osmo-sgsn osmo-gbproxy"
+SYSTEMD_SERVICE_osmo-sgsn = "osmo-sgsn.service"
+SYSTEMD_SERVICE_osmo-gbproxy = "osmo-gbproxy.service"
+
+FILES_osmo-gbproxy = " \
+ ${bindir}/osmo-gbproxy \
+ ${sysconfdir}/osmocom/osmo-gbproxy.cfg \
+ "
+
+FILES_osmo-gtphub = " \
+ ${bindir}/osmo-gtphub \
+ ${sysconfdir}/osmocom/osmo-gtphub.cfg \
+ "
+
+FILES_osmo-gbproxy-doc = " ${docdir}/osmo-sgsn/examples/osmo-gbproxy "
+FILES_osmo-gtphub-doc = " ${docdir}/osmo-sgsn/examples/osmo-gtphub "
diff --git a/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb b/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb
new file mode 100644
index 0000000..e94618f
--- /dev/null
+++ b/recipes-osmocom/osmo-sgsn/osmo-sgsn_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "341d446b4db87b48812afe8d2149ebc840e8a357"
+SRC_URI = "git://git.osmocom.org/osmo-sgsn.git;protocol=git"
+PV = "0.1.0+gitr${SRCPV}"
+PR = "${INC_PR}.0"