aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-09-26 14:28:49 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-09-29 14:04:26 +0200
commitb4eb971657d68322d11064e45012d2b4adf29e93 (patch)
treeddae8a8af0d7ddef17858057a2fada9e91271350
parent254389b473e392d97adfa666c25f1b565d2d3059 (diff)
osmo-mgw: Introduce recipe
-rw-r--r--recipes-osmocom/osmo-mgw/osmo-mgw.inc22
-rw-r--r--recipes-osmocom/osmo-mgw/osmo-mgw_git.bb7
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-osmocom/osmo-mgw/osmo-mgw.inc b/recipes-osmocom/osmo-mgw/osmo-mgw.inc
new file mode 100644
index 0000000..45ee338
--- /dev/null
+++ b/recipes-osmocom/osmo-mgw/osmo-mgw.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "Osmocom Media Gateway (MGCP) implementation"
+HOMEPAGE = "https://osmocom.org/projects/osmo-mgw"
+LICENSE = "AGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+DEPENDS = "libosmocore libosmo-netif bcg729 libgsm"
+
+INC_PR="r0.${META_TELEPHONY_OSMO_INC}"
+
+inherit autotools pkgconfig systemd
+
+EXTRA_OECONF += "--enable-mgcp-transcoding --with-g729"
+
+do_install_append() {
+ install -d ${D}${systemd_system_unitdir}/
+ install -d ${D}${sysconfdir}/osmocom/
+
+ install -m 0644 ${S}/doc/examples/osmo-bsc_mgcp/mgcp.cfg ${D}${sysconfdir}/osmocom/osmo-bsc-mgcp.cfg
+ install -m 0644 ${S}/contrib/systemd/osmo-bsc-mgcp.service ${D}${systemd_system_unitdir}/
+}
+
+SYSTEMD_SERVICE_osmo-mgw = "osmo-bsc-mgcp.service"
diff --git a/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb b/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb
new file mode 100644
index 0000000..1ea1a7b
--- /dev/null
+++ b/recipes-osmocom/osmo-mgw/osmo-mgw_git.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+SRCREV = "1c8d67d7f5f6f8788d92df65a0b68e0ec19a34dc"
+SRC_URI = "git://git.osmocom.org/osmo-mgw.git;protocol=git"
+PV = "1.0.2+gitr${SRCPV}"
+PR = "${INC_PR}.0"