aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 7b245b1..bedd9e0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,9 +4,16 @@
#export DH_VERBOSE=1
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
%:
dh $@ --with autoreconf --fail-missing
override_dh_strip:
dh_strip --dbg-package=libsmpp34-dbg
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf