aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-11-09 09:12:42 +0100
committerHarald Welte <laforge@gnumonks.org>2012-11-09 09:12:42 +0100
commit9288d59cfdc452fa3a92728149537372ee5c6c56 (patch)
treec40d87d50e919086584cad6e1bad6e1b8ab8baa5 /configure.ac
parenta52c99e9e699f5ad264908bf9b19e349c4bcfd9e (diff)
auto-foo: Build test apps with libxml2 only if it is available
And disable the smsc build as it depends on libosmocore
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ee5e68f..1f7f129 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,10 @@ AC_PROG_INSTALL
AC_HEADER_STDC
AC_CHECK_HEADERS([malloc.h netinet/in.h stdint.h string.h])
+found_libxml2=yes
+PKG_CHECK_MODULES(LIBXML2, libxml-2.0, , found_libxml2=no)
+AM_CONDITIONAL(HAVE_LIBXML2, test "$found_libxml2" = yes)
+
# Checks for typedefs, structures, and compiler characteristics.
# Checks for library functions.