aboutsummaryrefslogtreecommitdiffstats
path: root/src/usb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/usb/Makefile.am')
-rw-r--r--src/usb/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/usb/Makefile.am b/src/usb/Makefile.am
index 2dee434b..c7d7a2a2 100644
--- a/src/usb/Makefile.am
+++ b/src/usb/Makefile.am
@@ -1,9 +1,9 @@
# This is _NOT_ the library release version, it's an API version.
# Please read chapter "Library interface versions" of the libtool documentation
# before making any modifications: https://www.gnu.org/software/libtool/manual/html_node/Versioning.html
-LIBVERSION=0:0:0
+LIBVERSION=0:1:0
-AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir)
AM_CFLAGS = -fPIC -Wall $(LIBUSB_CFLAGS) $(TALLOC_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
@@ -12,9 +12,12 @@ if ENABLE_LIBUSB
lib_LTLIBRARIES = libosmousb.la
libosmousb_la_SOURCES = osmo_libusb.c
-libosmousb_la_LDFLAGS = -version-info $(LIBVERSION)
+libosmousb_la_LDFLAGS = \
+ -version-info $(LIBVERSION) \
+ -no-undefined \
+ $(NULL)
libosmousb_la_LIBADD = \
- $(top_builddir)/src/libosmocore.la \
+ $(top_builddir)/src/core/libosmocore.la \
$(TALLOC_LIBS) \
$(LIBUSB_LIBS)