aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 11541967..abf7bf47 100644
--- a/configure.in
+++ b/configure.in
@@ -31,11 +31,15 @@ dnl Generate the output
AM_CONFIG_HEADER(config.h)
AC_ARG_ENABLE(talloc,
- [ --disable-talloc Support message buffer ],
+ [ --disable-talloc Disable building talloc memory allocator ],
[enable_talloc=0], [enable_talloc=1])
-
AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
+AC_ARG_ENABLE(tests,
+ [ --disable-tests Disable building test programs ],
+ [enable_tests=0], [enable_tests=1])
+AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
+
AC_OUTPUT(
libosmocore.pc
include/osmocore/Makefile