aboutsummaryrefslogtreecommitdiffstats
path: root/tests/lapd/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-12-11 20:25:12 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-12-11 21:35:06 +0100
commit72bd4eb3b9e674d771d911e27cacb45468d51487 (patch)
treeb5f5b170841055ddfe663c6fc2611214ef8611d8 /tests/lapd/Makefile.am
parentd318e6160795ac8c339e27d521248144c841f113 (diff)
lapdm: Create a simple test case to transmit data between both ends0.4.1
This is testing the establishment of two ends (BTS, MS) one is in the polling mode as used by osmo-bts. Transfer data between the two ends. The sent data is not verified though. This should be followed up soon.
Diffstat (limited to 'tests/lapd/Makefile.am')
-rw-r--r--tests/lapd/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/lapd/Makefile.am b/tests/lapd/Makefile.am
new file mode 100644
index 00000000..f7e2ab0e
--- /dev/null
+++ b/tests/lapd/Makefile.am
@@ -0,0 +1,9 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_FLAGS = -Wall -O0
+noinst_PROGRAMS = lapd_test
+EXTRA_DIST = lapd_test.ok
+
+lapd_test_SOURCES = lapd_test.c
+lapd_test_LDADD = \
+ $(top_builddir)/src/libosmocore.la \
+ $(top_builddir)/src/gsm/libosmogsm.la