aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2019-08-06 19:56:16 +0200
committerHarald Welte <laforge@osmocom.org>2021-01-06 00:22:13 +0100
commite4cd267ab18f2d9d66351cce5b5a1aa8cc893c51 (patch)
tree55051be67c00075cca55bc06b597f3c02a5ea414 /tests/Makefile.am
parent463dca0b9c57f080e8c3c96ad86deca3a6c48424 (diff)
Add inter-thread queue
This adds an inter-thread queue "it_q" to libosmocore. With it_q, one can perform thread-safe enqueing of messages to another thread, who will receive the related messages triggered via an eventfd handled in the usual libosmocore select loop abstraction. Change-Id: Ie7d0c5fec715a2a577fae014b0b8a0e9c38418ef
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f769603f..e0220bd8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -41,6 +41,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
gad/gad_test \
bsslap/bsslap_test \
bssmap_le/bssmap_le_test \
+ it_q/it_q_test \
$(NULL)
if ENABLE_MSGFILE
@@ -304,6 +305,9 @@ bsslap_bsslap_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
bssmap_le_bssmap_le_test_SOURCES = bssmap_le/bssmap_le_test.c
bssmap_le_bssmap_le_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
+it_q_it_q_test_SOURCES = it_q/it_q_test.c
+it_q_it_q_test_LDADD = $(LDADD)
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -389,6 +393,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
gad/gad_test.ok \
bsslap/bsslap_test.ok \
bssmap_le/bssmap_le_test.ok \
+ it_q/it_q_test.ok \
$(NULL)
if ENABLE_LIBSCTP