aboutsummaryrefslogtreecommitdiffstats
path: root/src/sim/Makefile.am
diff options
context:
space:
mode:
authorAndreas Rottmann <a.rottmann@gmx.at>2015-05-17 16:31:54 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2015-05-17 19:19:09 +0200
commit9eb1c800205b921c8e471c90e9fe8c5c4108aef0 (patch)
tree92e8b8fd8e815a49ddaf0cd83d88b1964f55a38a /src/sim/Makefile.am
parent16082fd3cda0ced8f22736e92394348ee2ecfda3 (diff)
build: Fix out-of-tree builds
Fixes: In file included from ../../../include/osmocom/core/msgb.h:25:0, from ../../../include/osmocom/sim/sim.h:4, from ../../../src/sim/reader_pcsc.c:30: ../../../include/osmocom/core/bits.h:6:35: fatal error: osmocom/core/bit16gen.h: No such file or directory #include <osmocom/core/bit16gen.h> In file included from ../../include/osmocom/core/msgb.h:25:0, from ../../utils/osmo-sim-test.c:26: ../../include/osmocom/core/bits.h:6:35: fatal error: osmocom/core/bit16gen.h: No such file or directory #include <osmocom/core/bit16gen.h>
Diffstat (limited to 'src/sim/Makefile.am')
-rw-r--r--src/sim/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/sim/Makefile.am b/src/sim/Makefile.am
index 185e8dfb..e241dc91 100644
--- a/src/sim/Makefile.am
+++ b/src/sim/Makefile.am
@@ -2,7 +2,7 @@
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
LIBVERSION=0:0:0
-INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include
AM_CFLAGS = -fPIC -Wall $(PCSC_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)