aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2011-03-23 18:08:08 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-23 18:08:08 +0100
commitfba495e5f6084800c076e0ecae990ed9e6483530 (patch)
tree0f9513f0f54bd01ccfdceb172b4fe14b3cabd16b /src/gsm/Makefile.am
parent04139f14b6197e3ec996133a945af3fa8a68fb7a (diff)
This patch moves the GSM-specific functions to the new library
libosmogsm which is provided by libosmocore. I have also moved generate_backtrace() to backtrace.c instead of gsm_utils.c, otherwise the timer and msgfile tests depend on libosmogsm. Signed-off-by: Pablo Neira Ayuso <pablo@gnumonks.org>
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
new file mode 100644
index 00000000..a8c2e569
--- /dev/null
+++ b/src/gsm/Makefile.am
@@ -0,0 +1,13 @@
+# This is _NOT_ the library release version, it's an API version.
+# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
+LIBVERSION=0:0:0
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -fPIC -Wall
+
+lib_LTLIBRARIES = libosmogsm.la
+
+libosmogsm_la_SOURCES = rxlev_stat.c tlv_parser.c comp128.c gsm_utils.c \
+ rsl.c gsm48.c gsm48_ie.c gsm0808.c \
+ gprs_cipher_core.c gsm0480.c
+libosmogsm_la_LIBADD = $(top_builddir)/src/libosmocore.la