aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorPhilipp Maier <pmaier@sysmocom.de>2017-03-24 17:59:26 +0100
committerHarald Welte <laforge@gnumonks.org>2017-04-08 07:44:45 +0000
commit22401433aad9f19074229f00d4f3b091de4804ce (patch)
tree4155e659ad957a9b475762a2d78a8ba8b409e3f6 /src/gsm/Makefile.am
parentf7add0889c80f9f94af9985a752375e13f713cd9 (diff)
gsm0808: Add utils for AoIP Transport Layer Address
The planned support for true A over IP requires the encoding and decoding of a so called "AoIP Transport Layer Address" element. This commt adds parsing functionality and tests for the element mentioned above, however, it is not yet actively used. Change-Id: I57933b0a06a3f54ec2a41e6ecb6ced9fbbc89332
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 3a4a0cd3..e64c9e79 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -25,7 +25,7 @@ libgsmint_la_SOURCES = a5.c rxlev_stat.c tlv_parser.c comp128.c comp128v23.c \
auth_milenage.c milenage/aes-encblock.c gea.c \
milenage/aes-internal.c milenage/aes-internal-enc.c \
milenage/milenage.c gan.c ipa.c gsm0341.c apn.c \
- gsup.c gprs_gea.c gsm0503_conv.c oap.c
+ gsup.c gprs_gea.c gsm0503_conv.c oap.c gsm0808_utils.c
libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = $(top_builddir)/src/libosmocore.la