aboutsummaryrefslogtreecommitdiffstats
path: root/src/ctrl/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-04-16 17:26:30 +0200
committerHarald Welte <laforge@gnumonks.org>2017-04-27 09:50:47 +0200
commit31c0fef2fd5daa53617c05752411ec6446d8a82b (patch)
tree299c1643f09720801ae43b0936463e9d2d69b0a7 /src/ctrl/Makefile.am
parentf85861d6eb6ebc962bc710ac2d481536e6be7053 (diff)
control_if: Add control interface commands for FSMs
This allows programmatic access to introspection of FSM instances, which is quite handy from e.g. external test cases: Send a message to the code, then use the CTRL interface to check if that message has triggered the right kind of state transition. Change-Id: I0f80340ee9c61c88962fdd6764a6098a844d0d1e
Diffstat (limited to 'src/ctrl/Makefile.am')
-rw-r--r--src/ctrl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/ctrl/Makefile.am b/src/ctrl/Makefile.am
index 1817caca..e8d55e6b 100644
--- a/src/ctrl/Makefile.am
+++ b/src/ctrl/Makefile.am
@@ -8,7 +8,7 @@ AM_CFLAGS = -Wall $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/incl
if ENABLE_CTRL
lib_LTLIBRARIES = libosmoctrl.la
-libosmoctrl_la_SOURCES = control_cmd.c control_if.c
+libosmoctrl_la_SOURCES = control_cmd.c control_if.c fsm_ctrl_commands.c
libosmoctrl_la_LDFLAGS = $(LTLDFLAGS_OSMOCTRL) $(TALLOC_LIBS) -version-info $(LIBVERSION) -no-undefined
libosmoctrl_la_LIBADD = \