aboutsummaryrefslogtreecommitdiffstats
path: root/src/codec/Makefile.am
diff options
context:
space:
mode:
authorMychaela N. Falconia <falcon@freecalypso.org>2023-05-12 17:04:06 +0000
committerfalconia <falcon@freecalypso.org>2023-05-17 13:53:20 +0000
commit8fa13c66ac035cbd2fba2ffe2b844d6a6831853e (patch)
treef02cd204611d7d70f0d70a7140cbb273b63ae68e /src/codec/Makefile.am
parent8f026bf3b74293a9ed108937d1950b7453d6c5ef (diff)
codec cosmetic: move old FR ECU code to ecu_fr_old.c
The current FR codec ECU implementation consists of two parts: there is a pair of functions that implement the actual functionality, and these functions are also made public as a now-deprecated legacy API - and there is the new ECU abstraction. If the FR ECU implementation behind the generic ECU abstraction is to be changed to a different one, the old implementation still has to be retained for those public legacy osmo_ecu_fr_reset() and osmo_ecu_fr_conceal() API functions to remain available and unbroken. Move this legacy ECU implementation to its own C module in preparation for changing the preferred ECU implementation. Related: OS#6027 Change-Id: Ia169b8bcc6331227a11b78eb7ffca0c7ab838c69
Diffstat (limited to 'src/codec/Makefile.am')
-rw-r--r--src/codec/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/codec/Makefile.am b/src/codec/Makefile.am
index f05ac1f7..f7877fe2 100644
--- a/src/codec/Makefile.am
+++ b/src/codec/Makefile.am
@@ -13,6 +13,7 @@ endif
lib_LTLIBRARIES = libosmocodec.la
-libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c ecu.c ecu_fr.c
+libosmocodec_la_SOURCES = gsm610.c gsm620.c gsm660.c gsm690.c ecu.c ecu_fr.c \
+ ecu_fr_old.c
libosmocodec_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
libosmocodec_la_LIBADD = $(top_builddir)/src/core/libosmocore.la