aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2019-12-16 23:14:45 +0100
committerHarald Welte <laforge@osmocom.org>2019-12-17 13:49:28 +0100
commitc6a8697800376a02b868cdea8fc1bf55f12798f1 (patch)
treee42f7a62ae2a17efd8f10810dfc63d3e776c0809 /src/Makefile.am
parent22c7ec3b60d6544d3042a115d519b9311b6bee45 (diff)
Introduce helper functions for safe fork+exec of processes
In some situations, we want to execute an external shell command in a non-blocking way. Similar to 'system', but without waiting for the child to complete. We also want to close all file descriptors ahead of the exec() and filter + modify the environment. Change-Id: Ib24ac8a083db32e55402ce496a5eabd8749cc888 Related: OS#4332
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 99432811..eeb3f7df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -27,6 +27,7 @@ libosmocore_la_SOURCES = context.c timer.c timer_gettimeofday.c timer_clockgetti
tdef.c \
sockaddr_str.c \
use_count.c \
+ exec.c \
$(NULL)
if HAVE_SSSE3