aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-30 13:19:58 +0100
committerMax <msuraev@sysmocom.de>2017-10-30 13:50:31 +0100
commitba1059c173ac8f4845464c4f91d1890898f729a0 (patch)
treea2b56f276eedd8675f1b51f629fb551dd3bbccac /src/Makefile.am
parentd9abb0a70869bdf4546d9cd0de39461773a1638f (diff)
Move additional libraries to appropriate place
According to https://www.gnu.org/software/automake/manual/automake.html#Libtool-Flags the libraries supposed to be added to *_LDADD or *_LIBADD while *_LDFLAGS should contain additional libtool linking flags. Previously we used both. Let's unify this and move all the libraries into proper automake variable. While at it - also add libosmocore.la for tests to LDADD since all the tests link against it anyway. Change-Id: Ia657a66db75df831421af5df1175a992da5ba80f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cff5f449..e7f94cef 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,11 +44,11 @@ endif
BUILT_SOURCES = crc8gen.c crc16gen.c crc32gen.c crc64gen.c
EXTRA_DIST = conv_acc_sse_impl.h
+libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
+
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(TALLOC_LIBS) $(LIBRARY_DL) -no-undefined
-else
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(TALLOC_LIBS) -no-undefined
+libosmocore_la_LIBADD += $(LIBRARY_DL)
endif
if ENABLE_MSGFILE