aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2016-12-02 15:30:02 +0100
committerHarald Welte <laforge@gnumonks.org>2016-12-09 17:59:58 +0100
commitaa00f99be2e4cc64ede20d8c9548b83054696581 (patch)
treed18f900b36987bfaa990268b5f4902cf6a704810 /src/Makefile.am
parenta65e99331a9699a09d2661b595c1723eea51873f (diff)
Implement GSMTAP log target
This target wraps the to-be-logged string (With metadata) into a GSMTAP packet and sends it to the configured destination address. Change-Id: I9a7e72b8c9c6f6f2d76d1ea2332dcdee12394625
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 74bdb213..6a9c6758 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,7 +11,7 @@ libosmocore_la_LIBADD = $(BACKTRACE_LIB) $(TALLOC_LIBS)
libosmocore_la_SOURCES = timer.c timer_gettimeofday.c select.c signal.c msgb.c bits.c \
bitvec.c bitcomp.c statistics.c fsm.c \
write_queue.c utils.c socket.c \
- logging.c logging_syslog.c rate_ctr.c \
+ logging.c logging_syslog.c logging_gsmtap.c rate_ctr.c \
gsmtap_util.c crc16.c panic.c backtrace.c \
conv.c application.c rbtree.c strrb.c \
loggingrb.c crc8gen.c crc16gen.c crc32gen.c crc64gen.c \