aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2011-04-23 16:09:19 +0200
committerHarald Welte <laforge@gnumonks.org>2011-04-26 14:40:49 +0200
commit19dc5c9cca4357ca770f117c45e8baee38bf2c36 (patch)
treefe06a074f0a7651e20fdb6c5f62012cb0b77ed64 /src/Makefile.am
parentf1d33447814391967186222b64780a4abd150453 (diff)
core/conv: Add some generic code for convolutional coding/decoding
Far from perfect but suits our need thus far. The viterbi with softbit input is quite cpu-intensive. Since most received bursts are often mostly error free, you could use a less cpu intensive algorithm (Fano ?) and with hard bit input. Then only switch to viterbi soft bit input if the channel is bad enough to justify it. Soft output is not implemented as its usefulness for the block coding is limited. Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c5c8a21d..a0d639ca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,7 +14,7 @@ libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c bits.c \
write_queue.c utils.c \
logging.c logging_syslog.c rate_ctr.c \
gsmtap_util.c crc16.c panic.c backtrace.c \
- process.c
+ process.c conv.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c