aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2011-09-16 22:59:18 +0200
committerSylvain Munaut <tnt@246tNt.com>2011-09-16 22:59:18 +0200
commit2749c0bfbfed432e5cc8cba96b7732753c9ad1a2 (patch)
tree5585f841480ccfd9c5f790df63eb3d96b6ca2fe9 /src/Makefile.am
parentdef0afed23bbda21bb2bf27e6f5284e5557a1cd3 (diff)
core: Add generic CRC functions (templates expended to 8 16 32 64 bits)
Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 739095c8..b0ccaddb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,7 +14,8 @@ libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c bits.c \
write_queue.c utils.c socket.c \
logging.c logging_syslog.c rate_ctr.c \
gsmtap_util.c crc16.c panic.c backtrace.c \
- conv.c application.c
+ conv.c application.c \
+ crc8gen.c crc16gen.c crc32gen.c crc64gen.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c
@@ -34,3 +35,7 @@ endif
if ENABLE_SERIAL
libosmocore_la_SOURCES += serial.c
endif
+
+crc%gen.c: crcXXgen.c.tpl
+ @echo " SED $< -> $@"
+ @sed -e's/XX/$*/g' $< > $@