aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric <ewild@sysmocom.de>2020-07-23 02:16:46 +0200
committerlaforge <laforge@osmocom.org>2020-08-06 16:47:40 +0000
commit3afc1d1777e1c0dc0fe832db2c9746fb8a767fe3 (patch)
tree96f104934eb857ba1d66516f4df7e8e6865c9790 /src/Makefile.am
parent2c962f5de1eeea119cfac7d9d92db31c570353b9 (diff)
libomsocoding: NEON viterbi acceleration
configure flag required to enable this: --enable-neon Although autodetection according to __ARM_NEON would work because this is only defined if the fpu is neon neon-fp16 neon-vfpv3 neon-vfpv4 neon-fp-armv8 crypto-neon-fp-armv8 doing that would lead to a unknown performance impact, so it needs to be enabled manually. Speedup is about ~1.3-1.5 on a unspecified single core Cortex A9. This requires handling a special case for RACH with len 14 which is far too short for neon and would actually incur a performance penalty of 25%. Related: OS#4585 Change-Id: I58ff2cb4ce3514f43390ff0a2121f81e6a4983b5
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 16119d98..be097848 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -48,6 +48,11 @@ endif
endif
endif
+if HAVE_NEON
+libosmocore_la_SOURCES += conv_acc_neon.c
+# conv_acc_neon.lo : AM_CFLAGS += -mfpu=neon no, could as well be vfp with neon
+endif
+
BUILT_SOURCES = crc8gen.c crc16gen.c crc32gen.c crc64gen.c
EXTRA_DIST = conv_acc_sse_impl.h crcXXgen.c.tpl