aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2010-07-25 18:08:54 +0200
committerSylvain Munaut <tnt@246tNt.com>2010-07-25 18:08:54 +0200
commitac3e61a7a6b8f56b74d4ebd9c0fcb9c5935294b1 (patch)
tree894fd9150a39bb1442467bdb1867b07d2b475cfe /src/Makefile.am
parentf23ababfb2160f3189c19898c1ae5a987be1ba47 (diff)
core: Add some generic panic handling
This also includes an option for a minimal 'infinite loop' type panic that could be required for embedded target that don't have abort() or fprintf() Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a20fbc86..e197e179 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,7 @@ libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c rxlev_stat.c \
tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
write_queue.c utils.c rsl.c gsm48.c gsm48_ie.c \
logging.c gsm0808.c rate_ctr.c gsmtap_util.c \
- gprs_cipher_core.c crc16.c
+ gprs_cipher_core.c crc16.c panic.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c