aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-02-26 20:30:32 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-02-26 20:30:32 +0100
commit8df932a7fd1aecc5660f8b5db0f8f652db3d9474 (patch)
tree9a6997ebf15322e06a5de1f2f742a769de9f4318 /src/Makefile.am
parentd60c7a895e1bdfc37de7fe0a63c5c1a7b68cc0db (diff)
[write_queue] Add a generic write queue class
The write queue can be a dropin replacement for the bsc_fd. It is featuring two callbacks. One for ready read and one for ready write. Whenever there is a message in the queue the write_queue will set the BSC_FD_WRITE flag and then call the write callback. It will make sure to delete the msgb after the write function has been called. This class is intended to be be used in the osmocom, layer2, bsc_msc_ip, bsc_hack and other applications.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b82b6fb1..c0c94883 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -8,4 +8,5 @@ AM_CFLAGS = -fPIC -Wall
lib_LTLIBRARIES = libosmocore.la
libosmocore_la_SOURCES = msgb.c timer.c talloc.c select.c signal.c \
- tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c
+ tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
+ write_queue.c