aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-07 20:24:30 +0100
committerHarald Welte <laforge@gnumonks.org>2010-03-07 20:24:30 +0100
commitcbb29f7c94ad2a7cb0ebe7d43cbef5fb9d11d62e (patch)
tree83b5be0646f64acc70d4cb6e6826029f6dd57311 /src/Makefile.am
parentd3ff15fc818887be3720265b297ca7f1ec28c458 (diff)
add --disable-talloc option to build without talloc support
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 99424522..5122e73b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,6 +7,10 @@ AM_CFLAGS = -fPIC -Wall
lib_LTLIBRARIES = libosmocore.la
-libosmocore_la_SOURCES = msgb.c timer.c talloc.c select.c signal.c \
+libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c \
tlv_parser.c bitvec.c comp128.c gsm_utils.c statistics.c \
write_queue.c utils.c rsl.c gsm48.c rxlev_stat.c
+
+if ENABLE_TALLOC
+libosmocore_la_SOURCES += talloc.c
+endif