aboutsummaryrefslogtreecommitdiffstats
path: root/include/osmocom/core/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-06-29 13:01:19 -0700
committerHarald Welte <laforge@gnumonks.org>2012-06-30 22:01:43 +0200
commitd471a2192015440ec9b8c409268ba6433511f421 (patch)
treed5471b576480d0e670595d4163630616145d6dfc /include/osmocom/core/Makefile.am
parentea0e1eca2bc32b531242a3b0a3c471e492a6f493 (diff)
build: simplify headers management and remove recursion
There is no real reason to keep the include directory a multi-level recursion, so instead declare everything within include (so that we can use proper nobase_ declarations) and be it. Please note that since we removed the sub-Makefile.am, ./configure will not create the directory structure for us on out-of-tree builds, so we have to make sure the directory we're generating to exists first. Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'include/osmocom/core/Makefile.am')
-rw-r--r--include/osmocom/core/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/include/osmocom/core/Makefile.am b/include/osmocom/core/Makefile.am
deleted file mode 100644
index 1df111af..00000000
--- a/include/osmocom/core/Makefile.am
+++ /dev/null
@@ -1,31 +0,0 @@
-osmocore_HEADERS = signal.h linuxlist.h timer.h select.h msgb.h bits.h \
- bitvec.h statistics.h utils.h socket.h \
- gsmtap.h write_queue.h prim.h \
- logging.h rate_ctr.h gsmtap_util.h \
- crc16.h panic.h process.h linuxrbtree.h \
- backtrace.h conv.h application.h \
- crcgen.h crc8gen.h crc16gen.h crc32gen.h crc64gen.h
-
-noinst_HEADERS = timer_compat.h
-
-if ENABLE_PLUGIN
-osmocore_HEADERS += plugin.h
-endif
-
-if ENABLE_TALLOC
-osmocore_HEADERS += talloc.h
-endif
-
-if ENABLE_MSGFILE
-osmocore_HEADERS += msgfile.h
-endif
-
-if ENABLE_SERIAL
-osmocore_HEADERS += serial.h
-endif
-
-osmocoredir = $(includedir)/osmocom/core
-
-crc%gen.h: crcXXgen.h.tpl
- @echo " SED $< -> $@"
- @sed -e's/XX/$*/g' $< > $@