aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-12-05 23:38:18 +0100
committerHarald Welte <laforge@gnumonks.org>2015-12-05 23:38:18 +0100
commit90e614f7ccb0902e6ddb510bb10f78eb14a13d94 (patch)
treeb9e4d2365e3d387f1aebcee6bf0e32b4f4f1ff12 /include/Makefile.am
parentee702cd590688c1e65296319c5bc4c9cf160ba65 (diff)
remove our internal copy of talloc, use system libtalloc
Shipping our own private copy of talloc was a good idea in 2008, when it was not readily available on most target platforms. Today, the situation is quite different, as it is a standard library on major Linux distributions.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am16
1 files changed, 0 insertions, 16 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index b8739e02..07d6c00d 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -97,10 +97,6 @@ if ENABLE_PLUGIN
nobase_include_HEADERS += osmocom/core/plugin.h
endif
-if ENABLE_TALLOC
-nobase_include_HEADERS += osmocom/core/talloc-internal.h
-endif
-
if ENABLE_MSGFILE
nobase_include_HEADERS += osmocom/core/msgfile.h
endif
@@ -134,15 +130,3 @@ osmocom/core/bit%gen.h: osmocom/core/bitXXgen.h.tpl
osmocom/core/crc%gen.h: osmocom/core/crcXXgen.h.tpl
$(AM_V_GEN)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)sed -e's/XX/$*/g' $< > $@
-
-# regenerate talloc.h with config.status every time config.status changes
-osmocom/core/talloc.h: stamp-talloc
- :
-
-stamp-talloc: $(top_builddir)/config.status
- cd $(top_builddir) \
- && CONFIG_FILES= CONFIG_HEADERS= CONFIG_OTHER=osmocom/core/talloc.h \
- $(SHELL) ./config.status
- echo timestamp > $@
-
-DISTCLEANFILES = stamp-talloc