aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-02-20 21:09:24 +0100
committerHarald Welte <laforge@gnumonks.org>2010-02-20 21:09:24 +0100
commit3cae0398eaef6045de883849a236c38d1767cb41 (patch)
treee206fbaec0bb64687b98fe4db6d97ac3386be354 /configure.in
parent26cbdcff24d42b4387f2446d698ffbf18e4bcbef (diff)
add missing automake / autoconf files
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 00000000..a5c5f6b3
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,42 @@
+AC_INIT
+
+AM_INIT_AUTOMAKE(libosmocore, 0.0alpha1)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+AC_PROG_LIBTOOL
+
+dnl checks for header files
+AC_HEADER_STDC
+AC_CHECK_HEADERS(execinfo.h sys/select.h)
+
+# The following test is taken from WebKit's webkit.m4
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fvisibility=hidden "
+AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
+AC_COMPILE_IFELSE([char foo;],
+ [ AC_MSG_RESULT([yes])
+ SYMBOL_VISIBILITY="-fvisibility=hidden"],
+ AC_MSG_RESULT([no]))
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(SYMBOL_VISIBILITY)
+
+dnl Generate the output
+AM_CONFIG_HEADER(config.h)
+
+AC_OUTPUT(
+ libosmocore.pc
+ include/osmocore/Makefile
+ include/osmocore/protocol/Makefile
+ include/Makefile
+ src/Makefile
+ tests/Makefile
+ tests/timer/Makefile
+ tests/sms/Makefile
+ Makefile)