aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2020-03-15 22:50:06 +0100
committerHarald Welte <laforge@osmocom.org>2020-03-16 11:28:21 +0100
commit3c44a646bd036785fd54dd3ae9fb06d9d6d3d107 (patch)
tree3f2d773b0998760dc158982bca37e69a51972964 /configure.ac
parent3a5917bd5044eaf5327d15766a2ef900433b6627 (diff)
libosmosim: Build irrespective of PC/SC support
libosmosim contains a variety of definitions and utility fuinctions useful when working with SIM card [protocol]. They can not only be used with PC/SC readers but also in other contexts. Change-Id: I741940d3dc2a5653c760e9d1597d7f08afb3b631
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1056a0a2..3b4ad40e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,7 @@ AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC sup
])
AS_IF([test "x$ENABLE_PCSC" = "xyes"], [
PKG_CHECK_MODULES(PCSC, libpcsclite)
+ AC_DEFINE([HAVE_PCSC],[1],[Build with PC/SC support])
])
AM_CONDITIONAL(ENABLE_PCSC, test "x$ENABLE_PCSC" = "xyes")
AC_SUBST(ENABLE_PCSC)