aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2020-08-25 13:56:43 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2020-08-25 14:22:03 +0200
commit16b076cd15cdf5e3512656ee2e1bc55fa6afad53 (patch)
treef58f91a9126db97139288a6e87b641fd01874fd5 /configure.ac
parent3119d476034eff13ead05d8320244edc0ad089f2 (diff)
tests: Split SCTP tests to its own file and run them conditionally
Some systmes (like the ones available in OBS) don't support creating SCTP sockets, so we need to skip those tests there. Change-Id: I1d16280674625877ec22cc60cbc5deb67868a656
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fbdcb579..b07a3bd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,6 +197,10 @@ AS_IF([test "x$ENABLE_LIBSCTP" = "xyes"], [
LIBS=$old_LIBS
])
+AC_ARG_ENABLE([sctp-tests], [AS_HELP_STRING([--disable-sctp-tests], [Do not run socket tests requiring system SCTP support])],
+ [ENABLE_SCTP_TESTS=$enableval], [ENABLE_SCTP_TESTS="yes"])
+AM_CONDITIONAL(ENABLE_SCTP_TESTS, test x"$ENABLE_SCTP_TESTS" = x"yes")
+
AC_ARG_ENABLE(plugin,
[AS_HELP_STRING(
[--disable-plugin],