aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-07-06 10:45:22 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-07-06 10:45:26 +0200
commit639c408ec1325b97a72fba603064265b27687703 (patch)
treeaf0c8500629dfcdae1a275df43ca44f18bddeddf /configure.ac
parent1f82d0aecfa30884426fdcf583b32826527c639c (diff)
configure.ac: Add --disable-doxygen flag
This flag, when set, allows to unconditionally disable doxygen documentation generation, even if doxygen command is found. Change-Id: Iba1440292116af27b267c7a1fbec1c2336784efe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92544b68..96757df2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,8 +59,14 @@ AC_SUBST(LIBRARY_DL)
AC_CHECK_LIB(execinfo, backtrace, BACKTRACE_LIB=-lexecinfo, BACKTRACE_LIB=)
AC_SUBST(BACKTRACE_LIB)
+AC_ARG_ENABLE(doxygen,
+ [AS_HELP_STRING(
+ [--disable-doxygen],
+ [Disable generation of documentation using doxygen],
+ )],
+ [doxygen=$enableval], [doxygen="yes"])
AC_PATH_PROG(DOXYGEN,doxygen,false)
-AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false)
+AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false && test "x$doxygen" = "xyes")
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"