aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-11-17 11:41:34 +0100
committerHarald Welte <laforge@gnumonks.org>2017-11-17 11:44:22 +0100
commitb93f60f7cd4bebbe6c26a456ea0b394fcafc731f (patch)
tree9b3f1016596a2f15f9497369165db60b2e27d797 /configure.ac
parentd0682108964fe7928e75e24c450637a62331ad9f (diff)
conv_acc: Our code requires SSSE3, not just SSE3
The accelerated convolutional decoder uses SSSE3 instructions such as PSIGNW (via _mm_sign_epi16) which go beyond what SSE3 offers. So let's make sure we use the right compiler flag (-mssse3) and also the right runtime check. Without this patch, we would use illegal instructions e.g. on Opteron Gen3 such as Opteron 2427, which are also used as build.opensuse.org build hosts (build31 through build36) where we wouldn't pass "make check" as a result. Change-Id: I2754164384109f2821fd98ffb48f625893f2923d Fixes: OS#2386
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a8c1d2e3..f7acf05c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -281,7 +281,7 @@ then
AX_CHECK_SIMD
else
AM_CONDITIONAL(HAVE_AVX2, false)
- AM_CONDITIONAL(HAVE_SSE3, false)
+ AM_CONDITIONAL(HAVE_SSSE3, false)
AM_CONDITIONAL(HAVE_SSE4_1, false)
fi