aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-05-15 21:37:34 +0200
committerHarald Welte <laforge@gnumonks.org>2017-05-17 15:15:52 +0100
commit898ffefde4198a23a92810a9cf39ff6846f3bb39 (patch)
treeab4f79425d35ade4b542b0b6d57b58992408321f /configure.ac
parent7f24c155f5acd898cd49f9f429500461fa4fd8a5 (diff)
add libpseudotalloc as super-simplistic talloc replacement
In tightly embedded builds (--enable-embedded), we want the ability to replace talloc with a very simple heap allocator to avoid the complexity of talloc without modifying all our code that assumes talloc. This will break the hierarchical notion of the allocator, but libosmo{core,gsm,coding,codec} don't rely on that anyway. Change-Id: Ie341034076f242a813f081919dd09d845775ad35
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1dd5930e..04d126e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -194,6 +194,14 @@ AC_ARG_ENABLE(ctrl,
[enable_ctrl=$enableval], [enable_ctrl="yes"])
AM_CONDITIONAL(ENABLE_CTRL, test x"$enable_ctrl" = x"yes")
+AC_ARG_ENABLE(pseudotalloc,
+ [AS_HELP_STRING(
+ [--enable-pseudotalloc],
+ [Enable building pseudotalloc library],
+ )],
+ [enable_pseudotalloc=$enableval], [enable_pseudotalloc="no"])
+AM_CONDITIONAL(ENABLE_PSEUDOTALLOC, test x"$enable_pseudotalloc" = x"yes")
+
AC_ARG_ENABLE(embedded,
[AS_HELP_STRING(
[--enable-embedded],
@@ -211,6 +219,7 @@ then
AM_CONDITIONAL(ENABLE_UTILITIES, false)
AM_CONDITIONAL(ENABLE_GB, false)
AM_CONDITIONAL(ENABLE_PCSC, false)
+ AM_CONDITIONAL(ENABLE_PSEUDOTALLOC, true)
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
fi
@@ -287,6 +296,7 @@ AC_OUTPUT(
src/gsm/Makefile
src/gb/Makefile
src/ctrl/Makefile
+ src/pseudotalloc/Makefile
tests/Makefile
tests/atlocal
utils/Makefile