aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2017-06-17 23:18:11 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2017-06-18 10:40:18 +0200
commit69dfe5aeec3d2e08baa033309ac4b84712367ac6 (patch)
tree0d941dca8db309b916d1b63dd1672ec67da38650 /configure.ac
parentc2afe81d854ba4e8a1d68d588ffdfc83d14e3323 (diff)
Fix compilation warning on deprecated macro
A warning was printed even if the deprecation didn't apply to libosmocore because it is still allowed to use it internally. This patch fixes this case while still printing a warning if external projects build using libosmocore headers. Change-Id: I32212f20756f828af1017482a71e29e4b3adbad4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 04d126e2..340a8965 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,6 +235,9 @@ then
CPPFLAGS+=" -fsanitize=address -fsanitize=undefined"
fi
+CFLAGS+=" -DBUILDING_LIBOSMOCORE"
+CPPFLAGS+=" -DBUILDING_LIBOSMOCORE"
+
AC_ARG_ENABLE(simd,
[AS_HELP_STRING(
[--disable-simd],