aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-06-20 02:52:38 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-06-23 00:18:21 +0000
commit249fb71a2e124acb191b7cd4d2c3af6a45da4a5e (patch)
tree600070cfa152fba5f9ce0c4ba2d5fbd8c842be83 /Makefile.am
parent51816479bcd59b14b4a59940016d28b15cd3df95 (diff)
doxygen: add missing gb API doc generation
Files in include/osmocom/gprs/ and src/gb/ are not included in any doxygen generated API docs. Add Doxyfile.gb.in and adjust configure.ac and Makefile.am. Change-Id: Ieb64f497f55368e396872083237c9ff28da2dd93
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f6df9bb..b8de3cad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,11 +19,14 @@ if HAVE_DOXYGEN
html_DATA = $(top_builddir)/doc/html.tar
+doc: $(html_DATA)
+
$(html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/gsm/html/index.html \
$(top_builddir)/doc/vty/html/index.html \
$(top_builddir)/doc/codec/html/index.html \
- $(top_builddir)/doc/coding/html/index.html
+ $(top_builddir)/doc/coding/html/index.html \
+ $(top_builddir)/doc/gb/html/index.html
cd $(top_builddir)/doc && tar cf html.tar */html
$(top_builddir)/doc/core/html/index.html: $(SOURCES) Doxyfile.core
@@ -50,13 +53,18 @@ $(top_builddir)/doc/coding/html/index.html: Doxyfile.coding
mkdir -p doc/coding
$(DOXYGEN) Doxyfile.coding
+$(top_builddir)/doc/gb/html/index.html: $(SOURCES) Doxyfile.gb
+ @rm -rf doc/gb
+ mkdir -p doc/gb
+ $(DOXYGEN) Doxyfile.gb
+
install-data-hook:
cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
uninstall-hook:
- cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding}
+ cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding,gb}
-DX_CLEAN = doc/{core,gsm,vty,codec,coding}/html/search/* doc/{core,gsm,vty,codec,coding}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding}/doxygen_sqlite3.db doc/*.tag
+DX_CLEAN = doc/{core,gsm,vty,codec,coding,gb}/html/search/* doc/{core,gsm,vty,codec,coding,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,gb}/doxygen_sqlite3.db doc/*.tag
endif
MOSTLYCLEANFILES = $(DX_CLEAN)