aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-08-17 19:41:49 +0200
committerHarald Welte <laforge@gnumonks.org>2011-08-17 19:41:49 +0200
commit02624d27435c417df90fa7ccce26a5b51fa5c2eb (patch)
tree4ac7da30ef372c886d3444385ed9889c388c505c /Makefile.am
parent7992af018097c1db3ed124a4898cb9184ddfbf82 (diff)
doxygen automake integration: make sure the 'doc' directory exists
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 64f13dd0..5a999eb3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,18 +31,22 @@ $(doc_html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/core/html/index.html: $(SOURCES) Doxyfile
rm -rf doc/core
+ mkdir -p doc/core
$(DOXYGEN) Doxyfile
$(top_builddir)/doc/gsm/html/index.html: $(SOURCES) Doxyfile.gsm
rm -rf doc/gsm
+ mkdir -p doc/gsm
$(DOXYGEN) Doxyfile.gsm
$(top_builddir)/doc/vty/html/index.html: $(SOURCES) Doxyfile.vty
rm -rf doc/vty
+ mkdir -p doc/vty
$(DOXYGEN) Doxyfile.vty
$(top_builddir)/doc/codec/html/index.html: $(SOURCES) Doxyfile.codec
- rm -rf doc/vty
+ rm -rf doc/codec
+ mkdir -p doc/codec
$(DOXYGEN) Doxyfile.codec
install-data-hook: