aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-10-03 16:54:41 +0800
committerMax <msuraev@sysmocom.de>2017-10-04 16:26:37 +0200
commitee497f245e78929ddb69ba1f06d27bcc886f6597 (patch)
tree9607668bbfd79cc0cb8f685036a0da0b9f2c19b9 /Makefile.am
parentb697df0c4a008b80aad750e42947363f899b9301 (diff)
Fixup severe build performance issues
Make variable substitution calling bumpversion and other commands introduce by osmo-release.mk has severely slowed down builds. Inside the makefile we could use $(eval FOO:=$(shell...)) constructs to have variable substitution only happen once the 'release' target is executed. However, 'ifeq' and friends don't work with such late constructs. Let's shift all release action into a helper shell script that is called from the Makefile instead. This way we get the best of both worlds: No performance impact during normal builds, and the convenience of 'make release'. Modified-by: Max <msuraev@sysmocom.de> Related: OS#2524 Change-Id: I98b3b5fe3db39953cea969a9dfbb75889df2e1ea
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b358568..5f23673e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,6 +12,8 @@ pkgconfig_DATA = libosmocore.pc libosmocodec.pc libosmovty.pc libosmogsm.pc \
relengdir = $(includedir)
releng_DATA = osmo-release.mk
+dist_bin_SCRIPTS = osmo-release.sh
+
osmo-release.mk: git-version-gen
BUILT_SOURCES = $(top_srcdir)/.version
@@ -20,7 +22,7 @@ $(top_srcdir)/.version:
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
-EXTRA_DIST = git-version-gen .version README.md osmo-release.mk
+EXTRA_DIST = git-version-gen .version README.md osmo-release.mk osmo-release.sh
if HAVE_DOXYGEN